From The Mana World
  • Current status: Needs update
  • Maintainer: Shura
  • Requirements (test enviroment)
    • /etc/mk.conf
      • CFLAGS = "-O2 -march=i686"
      • CXXFLAGS = "-O2 -march=i686"
    • GCC 3.3.3 (on setup)
    • NetBSD 2.0 release (on setup)
    • X.org 6.8.1 (pkgsrc)
    • Allegro 4.1.16 (pkgsrc) / modded
    • guichan 0.2.0 / customized CXXFLAGS & LDFLAGS
    • JGmod 0.99 / modded
  • Notes:
    • use gmake to compile (gmake -f makefile.static)
    • may have a huge slowdown because of unaccelerated video drivers
    • Allegro needs modification to work with guichan
      • /usr/pkg/include/allegro/internal/alconfig.h
        • change line 98 to: #define ZERO_SIZE_ARRAY(type, name) type name[1] / * ISO C99 flexible array members */
    • configure guichan like this (in bash)
    $ export CXXFLAGS=`allegro-config --cflags` 
    $ export LDFLAGS=`allegro-config --libs` 
    $ ./configure --prefix=/usr/pkg 
    • JGmod's makefile.lnx will not work out of the box, do the following:
      • first run
    $ sh fixunix.sh 
    
      • then replace src/makefile.lnx with the this one
      • run gmake in src/